import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?![^\\[\\]]*(?:\\([^[]]]*\\])?\\])|,(?![^\\{\\}]*(?:\\([^\\{\\}]]*\\})?\\})|\\{|\\}";
final String string = "{[d1].[m1], [d1].[m2]} , {[d1,mw],[d2].[d2,m2]}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}