$re = '/!.*?.(png|jpg|jpeg|bmp)(\|(thumbnail|(width=\d+,height=\d+)|(width=\d+)|(height=\d+)))?!/m';
$str = '!Screenshot 2023-01-09 at 11.30.10.png|width=476,height=137!
!Screenshot 2023-01-09 at 11.30.10.png|width=476!
!Screenshot 2023-01-09 at 11.30.10.png|height=137!
!image-2023-03-31-10-31-58-083.png!
!test_image.jpg!
!test_image.jpeg!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);