package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)!.*?.(png|jpg|jpeg|bmp)(\|(thumbnail|(width=\d+,height=\d+)|(width=\d+)|(height=\d+)))?!`)
var str = `!Screenshot 2023-01-09 at 11.30.10.png|width=476,height=137!
!Screenshot 2023-01-09 at 11.30.10.png|width=476!
!Screenshot 2023-01-09 at 11.30.10.png|height=137!
!image-2023-03-31-10-31-58-083.png!
!test_image.jpg!
!test_image.jpeg!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}