import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "!.*?.(png|jpg|jpeg|bmp)(\\|(thumbnail|(width=\\d+,height=\\d+)|(width=\\d+)|(height=\\d+)))?!";
final String string = "!Screenshot 2023-01-09 at 11.30.10.png|width=476,height=137!\n"
+ "!Screenshot 2023-01-09 at 11.30.10.png|width=476!\n"
+ "!Screenshot 2023-01-09 at 11.30.10.png|height=137!\n"
+ "!image-2023-03-31-10-31-58-083.png!\n"
+ "!test_image.jpg!\n"
+ "!test_image.jpeg!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}