import Foundation
let pattern = #"((?:https?:\/\/)?(?:www\.)?(?:\S+)?(?:\.\S+)?\.(?:com|io)(?:\/\S+)?(?:\?[\S]+)?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test.com
https://test.com
www.test.com
test.com/2022/test-test/123x456?test&test
test.com?test&123
subdomain.test.com?test&123
www.subdomain.test.com?test&123
test.io
https://test.io
www.test.io
test.io/2022/test-test/123x456?test&test
test.io?test&123
subdomain.test.io?test&123
www.subdomain.test.io?test&123
test.
test..
test...
test....
.test
..test
...test
....test
test.test
test..test
test...test
test....test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)