const regex = /((?:https?:\/\/)?(?:www\.)?(?:\S+)?(?:\.\S+)?\.(?:com|io)(?:\/\S+)?(?:\?[\S]+)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:https?:\\\/\\\/)?(?:www\\.)?(?:\\S+)?(?:\\.\\S+)?\\.(?:com|io)(?:\\\/\\S+)?(?:\\?[\\S]+)?)', 'gm')
const str = `test.com
https://test.com
www.test.com
test.com/2022/test-test/123x456?test&test
test.com?test&123
subdomain.test.com?test&123
www.subdomain.test.com?test&123
test.io
https://test.io
www.test.io
test.io/2022/test-test/123x456?test&test
test.io?test&123
subdomain.test.io?test&123
www.subdomain.test.io?test&123
test.
test..
test...
test....
.test
..test
...test
....test
test.test
test..test
test...test
test....test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}