$re = '/((?:https?:\/\/)?(?:www\.)?(?:\S+)?(?:\.\S+)?\.(?:com|io)(?:\/\S+)?(?:\?[\S]+)?)/m';
$str = 'test.com
https://test.com
www.test.com
test.com/2022/test-test/123x456?test&test
test.com?test&123
subdomain.test.com?test&123
www.subdomain.test.com?test&123
test.io
https://test.io
www.test.io
test.io/2022/test-test/123x456?test&test
test.io?test&123
subdomain.test.io?test&123
www.subdomain.test.io?test&123
test.
test..
test...
test....
.test
..test
...test
....test
test.test
test..test
test...test
test....test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);