$re = '/^\/api\/v1\/text\/(findTextsWithContextForMtop|findsOneTask|createTask)/';
$str = '/api/v1/text/findsOneTask';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);