using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/api\/v1\/text\/(findTextsWithContextForMtop|findsOneTask|createTask)";
string input = @"/api/v1/text/findsOneTask";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}