package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\/api\/v1\/text\/(findTextsWithContextForMtop|findsOneTask|createTask)`)
var str = `/api/v1/text/findsOneTask`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}