re = /^([A-Za-z ]+)\s*\|\s*([A-Za-z ]+)\s*\|\s*(\d+)$/m
str = 'Paduch | Karol | 21
Young | Travis | 25
Martin | Chris | 21
Zander Fanden | Buttfuck | 23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end