$re = '/^([A-Za-z ]+)\s*\|\s*([A-Za-z ]+)\s*\|\s*(\d+)$/m';
$str = 'Paduch | Karol | 21
Young | Travis | 25
Martin | Chris | 21
Zander Fanden | Buttfuck | 23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);