import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z ]+)\\s*\\|\\s*([A-Za-z ]+)\\s*\\|\\s*(\\d+)$";
final String string = "Paduch | Karol | 21\n"
+ "Young | Travis | 25\n"
+ "Martin | Chris | 21\n"
+ "Zander Fanden | Buttfuck | 23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}