re = /^\s*(?:<(p|div)(?:\s+[^>]*?)?>)?\s*(<span(?:\s+[^>]*?)?>\s*<\/span>|<br(?:\s+[^>]*?)?>| )*\s*(?:<\/\1>)?\s*$/i
str = ' <p > <span>acsd</span> dasf </p> '
# Print the match result
str.match(re) do |match|
puts match.to_s
end