import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:<(p|div)(?:\\s+[^>]*?)?>)?\\s*(<span(?:\\s+[^>]*?)?>\\s*<\\/span>|<br(?:\\s+[^>]*?)?>| )*\\s*(?:<\\/\\1>)?\\s*$";
final String string = " <p > <span>acsd</span> dasf </p> ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}