const regex = /^\s*(?:<(p|div)(?:\s+[^>]*?)?>)?\s*(<span(?:\s+[^>]*?)?>\s*<\/span>|<br(?:\s+[^>]*?)?>| )*\s*(?:<\/\1>)?\s*$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?:<(p|div)(?:\\s+[^>]*?)?>)?\\s*(<span(?:\\s+[^>]*?)?>\\s*<\\\/span>|<br(?:\\s+[^>]*?)?>| )*\\s*(?:<\\\/\\1>)?\\s*$', 'i')
const str = ` <p > <span>acsd</span> dasf </p> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}