// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?si)([ ._\-E](\d{1,4})[ ._\-])").unwrap();
let string = "[TEST](TRUC)One.pi.s01.ece.333.cccc.44.ne.33.xx.s01.xx.Piece.712.FANSUB.VOSTFR.(BIDULE).720p.[MACHIN].HDTV.x264-Kaerizaki";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}