$re = '/([ ._\-E](\d{1,4})[ ._\-])/si';
$str = '[TEST](TRUC)One.pi.s01.ece.333.cccc.44.ne.33.xx.s01.xx.Piece.712.FANSUB.VOSTFR.(BIDULE).720p.[MACHIN].HDTV.x264-Kaerizaki';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);