use strict;
my $str = '[TEST](TRUC)One.pi.s01.ece.333.cccc.44.ne.33.xx.s01.xx.Piece.712.FANSUB.VOSTFR.(BIDULE).720p.[MACHIN].HDTV.x264-Kaerizaki';
my $regex = qr/([ ._\-E](\d{1,4})[ ._\-])/sip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}