re = /([+-]?)(?:"([^"]*)"|'([^']*)'|([^\s+]+))/
str = 'ett+två apa "skala banan"aa \'korv"\' +smurf -hej hopp 000...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end