package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([+-]?)(?:"([^"]*)"|'([^']*)'|([^\s+]+))`)
var str = `ett+två apa "skala banan"aa 'korv"' +smurf -hej hopp 000...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}