using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+-]?)(?:""([^""]*)""|'([^']*)'|([^\s+]+))";
string input = @"ett+två apa ""skala banan""aa 'korv""' +smurf -hej hopp 000...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}