use strict;
my $str = 'https://client-eastwood-hue-prod-us.appspot.com.com.som.test/test/';
my $regex = qr/\.[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";