# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*//;t' <<< "https://client-eastwood-hue-prod-us.appspot.com.com.som.test/test/"