const regex = /\.[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.[[:alnum:]]*\\.?[[:alnum:]]*\\.?[[:alnum:]]*\\.?[[:alnum:]]*\\.?[[:alnum:]]*', '')
const str = `https://client-eastwood-hue-prod-us.appspot.com.com.som.test/test/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);