// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^(Prefeitura|Pref\.|P\.)\s(Municipal\s?|Mun.\s?|M.\s?)?(de\s)?(S[aã]o\sPaulo|S.\sP.|S.\sPaulo|S.P.|SP)$
").unwrap();
let string = "Prefeitura Municipal de São Paulo
Prefeitura Municipal de Sao Paulo
Prefeitura de São Paulo
Prefeitura de Sao Paulo
Prefeitura Mun. de São Paulo
Pref. Mun. de São Paulo
Pref. Mun. de S. P.
Pref. de São Paulo
Pref. de S. Paulo
Pref. M. de São Paulo
P. M. de Sao Paulo
Prefeitura São Paulo
Pref. Mun. São Paulo
Pref. Mun. S. Paulo
Prefeitura de S.P.
Prefeitura de SP";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}