using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Prefeitura|Pref\.|P\.)\s(Municipal\s?|Mun.\s?|M.\s?)?(de\s)?(S[aã]o\sPaulo|S.\sP.|S.\sPaulo|S.P.|SP)$
";
string input = @"Prefeitura Municipal de São Paulo
Prefeitura Municipal de Sao Paulo
Prefeitura de São Paulo
Prefeitura de Sao Paulo
Prefeitura Mun. de São Paulo
Pref. Mun. de São Paulo
Pref. Mun. de S. P.
Pref. de São Paulo
Pref. de S. Paulo
Pref. M. de São Paulo
P. M. de Sao Paulo
Prefeitura São Paulo
Pref. Mun. São Paulo
Pref. Mun. S. Paulo
Prefeitura de S.P.
Prefeitura de SP";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}