$re = '/^(Prefeitura|Pref\.|P\.)\s(Municipal\s?|Mun.\s?|M.\s?)?(de\s)?(S[aã]o\sPaulo|S.\sP.|S.\sPaulo|S.P.|SP)$
/mx';
$str = 'Prefeitura Municipal de São Paulo
Prefeitura Municipal de Sao Paulo
Prefeitura de São Paulo
Prefeitura de Sao Paulo
Prefeitura Mun. de São Paulo
Pref. Mun. de São Paulo
Pref. Mun. de S. P.
Pref. de São Paulo
Pref. de S. Paulo
Pref. M. de São Paulo
P. M. de Sao Paulo
Prefeitura São Paulo
Pref. Mun. São Paulo
Pref. Mun. S. Paulo
Prefeitura de S.P.
Prefeitura de SP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);