re = /(?P<tabela>[\S\.-]+)(?:\{)|\t(?P<nome>.*?)\:(?P<tipo>.*?)\:(?P<tamanho>.*?)(?:$)/mi
str = 'tabela{
campoA:int:
campoB:str:52
campoC:float:94
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end