#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?P<tabela>[\S\.-]+)(?:\{)|\t(?P<nome>.*?)\:(?P<tipo>.*?)\:(?P<tamanho>.*?)(?:$)"
Local $sString = "tabela{" & @CRLF & _
" campoA:int:" & @CRLF & _
" campoB:str:52" & @CRLF & _
" campoC:float:94" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")