const regex = new RegExp('(?P<tabela>[\\S\\.-]+)(?:\\{)|\\t(?P<nome>.*?)\\:(?P<tipo>.*?)\\:(?P<tamanho>.*?)(?:$)', 'gmi')
const str = `tabela{
campoA:int:
campoB:str:52
campoC:float:94
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}