# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"step.+\s+script: \".*blr/(.*).py\"\s+.*\s+args: \[([\"\w\W\s]+?)\]\n"
test_str = ("step1:\n"
" script: \"/workspace/feature-test-lib/tests/upgrade_blr/BQT.py\"\n"
" skip: 0\n"
" args: [\"testbed\"]\n"
" \n"
"step2:\n"
" script: \"/workspace/feature-test-lib/tests/upgrade_blr/DC_init.py\"\n"
" skip: 0\n"
" args: [\"testbed\", \"dcinit\"]\n"
" \n"
"step3:\n"
" script: \"/workspace/feature-test-lib/tests/upgrade_blr/sensor_upgrade.py\"\n"
" skip: 0\n"
" args: [\"testbed\", \"upgrade\"]\n"
" \n"
"step4:\n"
" script: \"/workspace/feature-test-lib/tests/upgrade_blr/Apply_Policy.py\"\n"
" skip: 0\n"
" args: [\"testbed\"]\n"
" \n"
"step5:\n"
" script: \"/workspace/feature-test-lib/tests/upgrade_blr/sensor_checks.py\"\n"
" skip: 0\n"
" args: [\"testbed\"]\n"
" \n"
"step6:\n"
" script: \"/workspace/feature-test-lib/tests/upgrade_blr/delete_device.py\"\n"
" skip: 0\n"
" args: [\"testbed\", \"dcinit\"]\n"
" \n"
"step7:\n"
" script: \"/workspace/feature-test-lib/tests/upgrade_blr/DC_init.py\"\n"
" skip: 0\n"
" args: [\"testbed\", \"dcinit\"]\n")
subst = "\\1, \\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.