using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"step.+\s+script: \"".*blr/(.*).py\""\s+.*\s+args: \[([\""\w\W\s]+?)\]\n";
string substitution = @"\1, \2";
string input = @"step1:
script: ""/workspace/feature-test-lib/tests/upgrade_blr/BQT.py""
skip: 0
args: [""testbed""]
step2:
script: ""/workspace/feature-test-lib/tests/upgrade_blr/DC_init.py""
skip: 0
args: [""testbed"", ""dcinit""]
step3:
script: ""/workspace/feature-test-lib/tests/upgrade_blr/sensor_upgrade.py""
skip: 0
args: [""testbed"", ""upgrade""]
step4:
script: ""/workspace/feature-test-lib/tests/upgrade_blr/Apply_Policy.py""
skip: 0
args: [""testbed""]
step5:
script: ""/workspace/feature-test-lib/tests/upgrade_blr/sensor_checks.py""
skip: 0
args: [""testbed""]
step6:
script: ""/workspace/feature-test-lib/tests/upgrade_blr/delete_device.py""
skip: 0
args: [""testbed"", ""dcinit""]
step7:
script: ""/workspace/feature-test-lib/tests/upgrade_blr/DC_init.py""
skip: 0
args: [""testbed"", ""dcinit""]
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}