re = /^(\d{4})\-(0?[1-9]|1[012])\-(0?[1-9]|[12][0-9]|3[01]) ([0-1][0-9]|[2][0-3]):([0-5][0-9]):([0-5][0-9])$/
str = '2017-05-05 12:20:45'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end