package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d{4})\-(0?[1-9]|1[012])\-(0?[1-9]|[12][0-9]|3[01]) ([0-1][0-9]|[2][0-3]):([0-5][0-9]):([0-5][0-9])$`)
var str = `2017-05-05 12:20:45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}