const regex = /^"*status:([0-9]{1,3}), body:{"code":[0-9]{3},"message":([0-9a-z":\/\\\s-_.,]*?),"errorStack".*$/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^"*status:([0-9]{1,3}), body:{"code":[0-9]{3},"message":([0-9a-z":\\\/\\\\\\s-_.,]*?),"errorStack".*$', 'gi')
const str = `"status:400, body:{"code":400,"message":"transaction failed:01070333:3: Virtual Server /Common/agc_idp_10.app/agc_idp_10_vs illegally shares destination address, source address, service port, ip-protocol, and vlan with Virtual Server /Common/agc_200.app/agc_200_vs.","errorStack":[],"apiError":2}"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}