package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^"*status:([0-9]{1,3}), body:{"code":[0-9]{3},"message":([0-9a-z":\/\\\s-_.,]*?),"errorStack".*$`)
var str = `"status:400, body:{"code":400,"message":"transaction failed:01070333:3: Virtual Server /Common/agc_idp_10.app/agc_idp_10_vs illegally shares destination address, source address, service port, ip-protocol, and vlan with Virtual Server /Common/agc_200.app/agc_200_vs.","errorStack":[],"apiError":2}"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}