#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^"*status:([0-9]{1,3}), body:{"code":[0-9]{3},"message":([0-9a-z":\/\\\s-_.,]*?),"errorStack".*$"
Local $sString = ""status:400, body:{"code":400,"message":"transaction failed:01070333:3: Virtual Server /Common/agc_idp_10.app/agc_idp_10_vs illegally shares destination address, source address, service port, ip-protocol, and vlan with Virtual Server /Common/agc_200.app/agc_200_vs.","errorStack":[],"apiError":2}"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")