re = /^(?<weeks>\d{1,2})w\s(?<days>0?[0-6])d\s(?<hours>(?:0?|1|2(?=[0-3]))\d)h\s(?<minutes>(?:0?|[1-5])\d)m$/i
str = '00w 00d 21h 00m'
# Print the match result
str.match(re) do |match|
puts match.to_s
end