use strict;
my $str = '00w 00d 21h 00m';
my $regex = qr/^(?<weeks>\d{1,2})w\s(?<days>0?[0-6])d\s(?<hours>(?:0?|1|2(?=[0-3]))\d)h\s(?<minutes>(?:0?|[1-5])\d)m$/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}