import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<weeks>\\d{1,2})w\\s(?<days>0?[0-6])d\\s(?<hours>(?:0?|1|2(?=[0-3]))\\d)h\\s(?<minutes>(?:0?|[1-5])\\d)m$";
final String string = "00w 00d 21h 00m";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}