$re = '/^(?!.*SNAPSHOT).*$/m';
$str = 'SNAPSHOT
SNAPSHOT.01.1
102.1.1.SNAPSHOT.ra
aaaa
dfadfa
dccc
ccccc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);