import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*SNAPSHOT).*$";
final String string = "SNAPSHOT\n"
+ "SNAPSHOT.01.1\n"
+ "102.1.1.SNAPSHOT.ra\n"
+ "aaaa\n"
+ "dfadfa\n"
+ "dccc\n"
+ "ccccc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}