using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*SNAPSHOT).*$";
string input = @"SNAPSHOT
SNAPSHOT.01.1
102.1.1.SNAPSHOT.ra
aaaa
dfadfa
dccc
ccccc
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}