use strict;
my $str = '[FIX]: Fix bad wiring on plane 334, 335,
and 336. Remove decorator for 446.
Description:
1. sadsadad.
2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd.
3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas.
Reference: #232
([\\d]+\\. )(.*?)(?=([\\d]+\\.)|($))
((?<=Description\\:[\\r\\n|\\r|\\n])(\\d+\\.|\\-)\\ (?P<desc>(.+)\\.))|((?<=\\.[\\r\\n|\\r|\\n])((\\d+\\.|\\-)\\ (?P<desc2>(.+)\\.))(?=[\\r\\n|\\r|\\n](\\d+\\.|\\-)|[\\r\\n|\\r|\\n]*Reference))';
my $regex = qr/((?<=Description\:[\r\n|\r|\n])(\d+\.|\-)\ (?P<desc>(.+)\.))|((?<=\.[\r\n|\r|\n])((\d+\.|\-)\ (?P<desc2>(.+)\.))(?=[\r\n|\r|\n](\d+\.|\-)|[\r\n|\r|\n]*Reference))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}