using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=Description\:[\r\n|\r|\n])(\d+\.|\-)\ (?P<desc>(.+)\.))|((?<=\.[\r\n|\r|\n])((\d+\.|\-)\ (?P<desc2>(.+)\.))(?=[\r\n|\r|\n](\d+\.|\-)|[\r\n|\r|\n]*Reference))";
string input = @"[FIX]: Fix bad wiring on plane 334, 335,
and 336. Remove decorator for 446.
Description:
1. sadsadad.
2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd.
3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas.
Reference: #232
([\d]+\. )(.*?)(?=([\d]+\.)|($))
((?<=Description\:[\r\n|\r|\n])(\d+\.|\-)\ (?P<desc>(.+)\.))|((?<=\.[\r\n|\r|\n])((\d+\.|\-)\ (?P<desc2>(.+)\.))(?=[\r\n|\r|\n](\d+\.|\-)|[\r\n|\r|\n]*Reference))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}