const regex = new RegExp('((?<=Description\\:[\\r\\n|\\r|\\n])(\\d+\\.|\\-)\\ (?P<desc>(.+)\\.))|((?<=\\.[\\r\\n|\\r|\\n])((\\d+\\.|\\-)\\ (?P<desc2>(.+)\\.))(?=[\\r\\n|\\r|\\n](\\d+\\.|\\-)|[\\r\\n|\\r|\\n]*Reference))', 'g')
const str = `[FIX]: Fix bad wiring on plane 334, 335,
and 336. Remove decorator for 446.
Description:
1. sadsadad.
2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd.
3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas.
Reference: #232
([\\d]+\\. )(.*?)(?=([\\d]+\\.)|(\$))
((?<=Description\\:[\\r\\n|\\r|\\n])(\\d+\\.|\\-)\\ (?P<desc>(.+)\\.))|((?<=\\.[\\r\\n|\\r|\\n])((\\d+\\.|\\-)\\ (?P<desc2>(.+)\\.))(?=[\\r\\n|\\r|\\n](\\d+\\.|\\-)|[\\r\\n|\\r|\\n]*Reference))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}