re = /<(a+) (?!(?:href=(["|']+)([http:\/\/])*link\.com([\/])?(.*?)["|'])) *[^>]*>(.*?)[^>]>/m
str = '<a href="google.ru">test</a>
<a href="http://link.com"></a>
<a href=\'sterium.com\'></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end