const regex = /<(a+) (?!(?:href=(["|']+)([http:\/\/])*link\.com([\/])?(.*?)["|'])) *[^>]*>(.*?)[^>]>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(a+) (?!(?:href=(["|\']+)([http:\\\/\\\/])*link\\.com([\\\/])?(.*?)["|\'])) *[^>]*>(.*?)[^>]>', 'gm')
const str = `<a href="google.ru">test</a>
<a href="http://link.com"></a>
<a href='sterium.com'></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}