using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(a+) (?!(?:href=([""|']+)([http:\/\/])*link\.com([\/])?(.*?)[""|'])) *[^>]*>(.*?)[^>]>";
string input = @"<a href=""google.ru"">test</a>
<a href=""http://link.com""></a>
<a href='sterium.com'></a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}